SixAiy - Maintenance / Version Upgrade / Voice Fix – Incident details

All systems operational

Maintenance / Version Upgrade / Voice Fix

Monitoring
Partial outage 30 %
Started 14 days ago

Affected

GensokyoBot

Major outage from 10:42 AM to 2:14 PM, Operational from 2:14 PM to 7:40 PM, Partial outage from 7:40 PM to 7:59 PM, Operational from 7:59 PM to 12:00 AM

Discord Bot

Major outage from 10:42 AM to 2:14 PM, Operational from 2:14 PM to 7:40 PM, Partial outage from 7:40 PM to 7:59 PM, Operational from 7:59 PM to 12:00 AM

Updates
  • Update
    Update

    We have also repaired the new Galnet command now removing a webhook from galnet is easy as typing /galnet remove select_channel_by_name

  • Monitoring
    Monitoring

    We have applied a patch to the bot, it should fix the random shard crashing and also fix the random crashing when the bot errors out for stupid reasons.

  • Identified
    Identified

    We have found another bug >.<, we though we caught them all but not all of them it seems, we will apply a quick patch to see if we can fix the issue.

  • Update
    Update

    Upgrades have been completed, we will continue to monitor the bot for the next few weeks making sure it hasn't got anymore problems.

  • Monitoring
    Monitoring

    The bot will be going down maintenance, we are preforming and version upgrade and the bot won't be available for the next few hours.